Top Stories

More From Our Blogs

華為交換機常用命令(以s5700-SI為例)

交換機的三種模式:

Access模式:

一般用來連接計算機與交換機. 此模式下有一個PVID就是本端口所屬的VLAN號,如果從鏈路上收到無標簽的幀,則打上默認VLAN號,然后發給其他端口,如果從鏈路上收到有標簽的幀,如果這個幀的VLAN等于PVID,則直接發給其他端口,如果不等于PVID,則直接丟棄.如果從其他端口收到一個有標簽的幀,且VLAN等于PVID,則直接剝離掉標簽從此端口發出,如果此標簽不等于PVID,則直接丟棄.

Trunk模式:

一般用于各交換機之間連接.此模式下有一個PVID和允許通過的VLAN ID列表. 如果從鏈路上收到一個不帶標簽的幀,則直接打上PVID號,轉發到其他端口, 如果從鏈路上收到一個帶標簽的幀,且此幀的VLAN號在允許通過的VLAN列表里,則直接轉發給其他端口; 如果從其他端口收到一個有標簽的幀,且此幀的VLAN等于PVID,則直接剝離掉標簽,并從此端口發出,如果此標簽不等于PVID,則查看此幀的VLAN號是否在允許通過的VLAN列表里,如果在,則直接從此端口發出,否則丟棄.

Hybrid模式:

此模式下,有一個默認的PVID號,一個untagged列表和一個tagged列表. 如果從鏈路上收到一個無標簽的幀,則打上PVID號,轉發到其他端口,如果從鏈路上收到一個帶標簽的幀,且此幀的VLAN號在untagged或者tagged列表中的其中任意一個列表里,則直接轉發到其他端口,否則丟棄. 如果從其他端口收到一個有標簽的幀,且幀的VLAN號在tagged列表里,則直接從此端口發出,如果VLAN號在untagged列表里,這剝離掉幀的VLAN標簽,然后從此端口發出.
華為交換機的三種視圖: 用戶視圖, 系統視圖, 接口視圖

用戶視圖: 剛開始登入交換機時的視圖,一般看到的是尖括號<> .

save    // 配置完交換機后保存當前配置的命令
system-view    // 進入系統視圖的命令
clock  timezone  BJ  add|minus 8   // 設置時區
clock  datetime  16:36:00 2016-07-01    //設置交換機的時間




系統視圖: 在用戶視圖下輸入system-view后進入系統視圖,一般為方括號[]

display current-configuration  // 顯示當前配置
user-interface maximum-vty 15  //配置vty最大連接數
user-interface vty 0 14     //進入vty用戶界面視圖
user privilege level 2      //設置vty登入的用戶等級為2(配置用戶級別)
authentication-mode aaa  //設置vty登入時的驗證模式為用戶名和密碼驗證

aaa  //進入AAA視圖
local-user admin password cipher admin@123  //設置aaa登入的用戶名和密碼
local-user admin service-type telnet  //設置admin用戶遠程登入時的協議

user-interface console 0     //進入第0個console口的用戶界面
authentication-mode passwd   //配置從console口登入交換機的認證模式為密碼認證
set authentication password cipher admin@123  //配置從console口登入交換機的密碼

vlan 10  //創建一個VLAN


interface meth 0/0/1   //進入交換機的第一個管理網口
ip address 192.168.1.110 24 //設置管理網口的ip地址和子網掩碼

interface gigabitethernet 0/0/1 //進入第一個業務網口
port link-type access  //設置第1個網口位access模式
port default vlan 10   //設置此網口的VLAN號為10

interface gigabitethnet 0/0/2 //進入第2個業務網口
port link-type trunk   //設置第二個網口位trunk模式
port trunk allow-pass vlan 10 20 30  //設置此端口可以通過的VLAN號
             // port trunk allow-pass vlan all  表示可以通過所有的帶VLAN的幀

Interface gigabitethnet 0/0/3  //進入第3個業務網口
Port link-type hybrid     //設置此端口為hybrid模式,每個端口默認就是hybrid模式
Port hybrid pvid vlan 10   //設置pvid為10
Port hybrid tagged vlan 20 30 40 //設置tagged列表為20,30,40
Port hybrid untagged vlan 50 60 //設置untagged列表為50,60

Display port vlan  //顯示當前各端口的VLAN情況

Port-group       //對端口批量操作 如:改成access模式,加入vlan 100

port-group group-member GigabitEthernet 0/0/1 to GigabitEthernet 0/0/10

port  link-type access

port default vlan 100

undo port link-type 

undo port default vlan  //批量清楚vlan



清除某個端口的配置

Interface gigabitethernet 0/0/2
Clear configuration this
Undo shutdown

Interface gigabitethernet 0/0/3
Undo port default vlan  //access 模式的端口
Undo port link-type
Undo port hybrid pvid vlan vlanid  //hybrid 模式的端口
Undo port hybrid untagged vlan vlanid
Undo port hybrid tagged vlan vlanid
Undo port trunk pvid vlan  //trunk 模式的端口
Undo port trunk allow-pass vlan vlanid
Undo port link-type



恢復出廠設置s5700SI
在用戶視圖下(按Ctrl+z組合鍵回到用戶視圖)輸入如下命令操作

reset saved-configuration
Y
Reboot
N
Y





設置交換機的mux-vlan模式
假設主VLAN是10,從VLAN中group模式的有VLAN 20, separate模式的有VLAN 30,server連接1號端口,PC1和PC2連接2和3號端口,PC3和PC4連接4和5號端口

Vlan batch 10 20 30
Vlan 10
Mux-vlan
Subordinate group 20
Subordinate separate 30


把各連接的端口設為access模式,并且加入到各自的VLAN中,且同時開啟mux-vlan功能,

Interface gigabitethernet 0/0/1        
Port link-type access
Port default vlan 10
Port mux-vlan enable
Interface gigabitethernet 0/0/2       //3號端口設置方法類似
Port link-type access
Port default vlan 20
Port mux-vlan enable
Interface gigabitethernet 0/0/4      //5號端口設置方法類似
Port link-type access
Port default vlan 30
Port mux-vlan enable




三層交換機接路由器LAN口

Vlan 60 70
Interface vlanif 60
ip address 192.168.60.1 24
interface vlanif 70
ip address 192.168.1.238 24
interface gigabitethernet 0/0/3
port link-type access
port default vlan 60
interface gigabitethernet 0/0/4
port link-type access
port default vlan 70
ip route-static 0.0.0.0 0.0.0.0 192.168.1.1


在與交換機相連的路由器上設置一條靜態ip地址,目的地址為交換機相關的各個網段地址,網關為交換機與路由器相連的vlanif的ip地址

批量配置交換機端口

vlan batch 10 20
port-group 1
group-member gigabitethernet 0/0/1 to gigabitethernet 0/0/10
port link-type access
port default vlan 10

Related Articles

H3C交換機基礎配置命令

H3C交換機基礎配置命令